 Author

Pedro V. Marcal, Snr.

San Diego,CA

marcalpv@msn.com


 Introduction

The Stock Market is a complex result of the interaction of all the economic activity of the United States. Because the Stock Exchanges also list the major companies of the World, we can also think that in some way the Markets also summarize the economic activity of the World. Most economists consider that the Markets are a perfect discounting mechanism, that is to say that the market prices contain all the relevant information that is available. Everyone brings a view of the market depending on one’s background and training. In the context of my own technical training it is not difficult to imagine the participants in the market simulating a neural net in which previous experience and current information are synthesized to yield a perfect market place. This information is fed into the market place as a price input to that stock that is judged the most representative and likely to profit most from the current information. It is clear that this results in a dynamic process where the stock price behaves as if it were controlled by a servomechanism searching for its balance point and using all the available feedback. Because the controlling events are random, we can expect that the concepts of probability will help considerably in aggregating the individual events into measurable quantities. The physical world has some analogs to the dynamic behavior that is exhibited in the marketplace. For example, accelerometers measuring the disturbances caused by an earthquake give readings similar to the price time plots of a stock. Indeed Hurst [1] in explaining market timing, uses some of the analytical tools used in earthquake analysis. Similarly the Elliot wave [2] can be seen as a simplification of Fourier analysis adapted to the market.

The purpose of market analysis is to predict the behavior of the stocks so that investors can invest intelligently. A huge effort is made by the Financial houses with specialist analysts who subject the economic performance of companies to intense scrutiny. These follow traditional valuation methods which are called Fundamental Analysis [ 3] [4]. This mode of analysis is in fact the triumph of Academic Finance Departments and is the culmination of much pioneering research and education. At the same time a large body of techniques has developed that are based on charting. The methodologies of Technical Analysis [5] are based on recognition of patterns which have been observed to repeat themselves. The ease with which the patterns can be analyzed have led to some recent authors applying the term Visual Analysis to Technical Analysis.[6]. Naturally the exponents of either method consider that the other method is inferior. This is a pity because both methods have their advantages and suffer from different drawbacks. A logical combination of both approaches could lead to a more dependable analysis. However both methods suffer from a basic disadvantage that is built into its assumption. This drawback is what I call linearity. By linearity I mean the linear extrapolation of one’s assumptions. Analysis is made today that based on a certain set of facts is projected into the future. To compound this, the market is already assumed to be capable of looking forward some six months. The real task then appears to be to project out to some period say six months and predict what the market will foresee at that time.

In this book we will concentrate mainly on Technical Analysis, but we will also take a look at some of the salient features from the random walk models. The simplest application of statistics in the random walk model will help us understand the power of Portfolio management and lead us to an understanding of the advantages of Mutual Funds in general and in indexed Funds in particular. In our Technical Analysis we will describe a complete set of tools based on numerical analysis. Numerical analysis is that branch of Applied Mathematics that allows us to express our mathematical concepts in discrete numbers. In the analysis of stock market behavior, we need to pay attention to two characteristic behaviors. One is the random nature of market forces that result in similar behavior of the stock prices. The second is the cyclic behavior of markets. These tools and their basis will be examined so that the reader can understand their origin and so be able to apply them intelligently. The tools are presented without mathematical rigor, its intent is to give the reader a flavor of the methods used rather than their absolute details. In selecting these tools I have chosen those which are widely available from any charting service which by now exist in large numbers on the internet. In many instances it would have been possible to develop software which would reflect some of the seminal work [1] [7] [8] with closer fidelity. However this would have taken us too far from our familiar tools. As already hinted at, we will approach the analysis of the market from a cyclic point of view. We will start with the current practice of defining the market as a set of weighted averages such as the Dow Jones Industrial Average, The Nasdaq composite index etc. We then examine the relation of individual stocks and their performance relative to these indices as proxies for the market. No Technical Analysis can be explained without considering the Dow theory. We note that the original Dow Theory already appealed to the concept of cyclic behavior to explain the action of the market. We will then introduce tools that will help us understand and predict the behavior of cycles. Bollinger Bands will be used to bound our cycles and Moving Average Convergence Divergence Plots (MACD) to help pinpoint their turning points. This will then be used to help us apply the Dow theory. We then examine the behavior of individual stocks and their behavior in a Portfolio as well as in a Mutual Fund. In building our arsenal of tools, we will also introduce the more traditional price volume curves and show how these plots may be used to advantage since these curves have been the traditional means of Technical Analysis.

In the final chapter we argue for an integrated deployment of all our tools. We organize these tools so that their results will confirm each other. This allows us in the end to place some confidence in our projections. A task made difficult by all the competing adversarial forces in the marketplace.

The purpose of this book is to help the reader develop skills in the analysis and understanding of the market. To this end practical exercises are suggested at the end of each chapter. The reader should take the time to work through these exercises.


 The Dow Theory

From the earliest days, it was well known that stocks moved up and down together. The Dow Theory was an attempt by Charles H. Dow to measure this movement by means of the average price of a selected number of stocks and to use these averages to predict the behavior of business trends. Mr. Dow founded the Dow-Jones Financial Service. In a number of editorials in the Wall Street Journal, he outlined the basic principles of what is now known as the Dow Theory. However it was left to William P. Hamilton, his successor at the Journal to organize the Dow Theory and formulate it in the form it is known today.

In order to follow the market, Dow established two indices. In the Industrial Average (DJIA) he placed 12 representative stocks (now at 30). In the Rails he placed 12 railroad stocks meant to represent the transportation stocks of the day. In its current form expanded to 20 stocks it is known as the Dow Jones Transportation average (DJTA). The DJTA has been expanded to include the Air transportation business. Here we see an early attempt to segment the market into two sectors. The DJIA measures the productive and manufacturing end of the market while the DJTA measures the delivery of the goods. Though both reflect the market conditions, the indices are arranged to exhibit the maximum orthogonality. Therefore when both indices rise and fall together, they confirm each other in determining the market trend.

The following are the basic tenets of the theory:-

  1. The Averages discount everything. The averages represent the combined information and judgement of all the participants in the trend and events affecting the markets. It is of course impossible to predict random natural disasters (Acts of God), but even in this case it is thought that once the event has occurred, the market is capable of assessing and discounting its impact.

  2. The Market moves with Three types of movement. The Primary movements are the broad over-all movement of the market and lasts for a period of more than a year. The Primary Movement is actually made up of a number of Intermediate up and down movements the effect of which is to keep the market moving in the direction of the Primary trend. The Secondary Reaction moves opposite to the primary trend. It generally lasts between three weeks and three months and typically retrace about a third to a half of the last intermediate move. Finally the market also follows a minor movement that typically lasts from a matter of hours to a period of two weeks. The minor movements are ignored by the Dow Theory. In Fig 1.1, we illustrate the Dow movements as a combination of two cycle movements. The first is a slowly increasing linear long term movement we also call this a cyclic movement. The second is a cyclic movement that is used to depict an intermediate cycle with a half cycle movement of 20 weeks. The two cycles are combined to show the Dow movement. The arrows A and B denote the Intermediate movement that forms part of the Primary trend. At B there is a Secondary reaction to the Arrow C. The combined curve then returns to its Primary uptrend. Until point D when another Secondary Reaction sets in. Some writers have drawn an analogy between the movement of the market and that of the sea. The Primary trend is like the tide. A Bull Market is a rising tide and a Bear Market is an ebbing tide. While a tide is rising or falling the height of the ocean is affected by the waves. These waves are likened to the intermediate movements of the market. If we were to observe the progress of the tide on the beach we would see that each wave (intermediate cycle) pushes the highest water level above its previous high level before retreating to a lower level. It may also be noted that this lower level will be higher than its predecessor. At some point the tide reaches its highest point and the process is reversed. Whereupon we have the start of the ebbing tide. This would correspond to a Bear Market. We cannot carry this analogy too far because the market does not behave with the regularity of the tides. Finally we note that during the whole period of rising or lowering of the tide eddy currents and ripples form with the waves. These are likened to the minor movements which are ignored in determining the level of the tides and also the level of the market.

With the advent of personal computers it is no longer necessary to draw such analogies to explain the movement of the market. The Dow movements shown in Fig. 1.1 gives a better picture of the changes that take place with time. An observer on the beach could place stakes on the ground to indicate positions on the curve shown as points A to D but the observer would not get as full a picture as shown by Fig. 1.1.

Returning to Fig. 1.1, we will use the pattern of higher peaks as well as higher valleys to determine the direction of the intermediate trend and the Secondary reaction, we also will have determined the Primary trend.

We will now illustrate our discussion by considering a weekly chart for the DJIA in Fig. 1.2. The Primary trend is a Bull Market. Starting from the lower left end of the chart in 6/96, we get to a first peak followed by a pullback to point A. This is followed by another advance to B, followed by a pullback to C. So far the upward trend is intact but in the next cycle we do not reach a higher peak this breaks the upward trend and indicates the possible start of a Secondary Reaction. The Secondary Reaction is confirmed by the next valley at point D. The next peak at E indicates that the Secondary Reaction is over and the upward trend resumes to the peak at F. A secondary reaction sets in till the valley at G. Again the next higher peaks indicate the resumption of the intermediate trend and a continuation of the Bull Market. The congestion at the next valley H is called a line in Dow Theory. A line indicates a continuation of the movement and is neutral. Its character is determined by the direction of its breakout. In this case the direction signals the continuation of the upward trend thus confirming the Bull Market.

Fig. 1.2 Weekly DJIA Chart

To complete this discussion we show the parameters that were used to create the chart. The chart was created by using the Big Charts charting service provided Free of charge at http://www.bigcharts.com/ The parameters that were used are shown by the next Fig. 1.3.

  3. The two averages must confirm. As we have seen in the previous discussion of the DJIA chart, there are frequent peaks and valleys and these peaks and valleys often return to the same levels that they have reached previously Fortunately we have two indices with unrelated stocks which we can use to confirm each other, ie. both indices can be used to determine the trend of the Market. The Dow Theory assumes that the Market trend continues in its previous direction until the Secondary movement is confirmed. We can determine this easily by a plot such as that in Fig. 1.4 which compares the DJTA with the DJIA.

Fig. 1.4 Comparison of DJTA and DJIA

In this comparison we see mostly a confirmation of the trend in DJIA. The point A is a lack of confirmation by the DJTA of the upward trend which could have been taken as a warning of an impending downtrend. The continuation of the downtrend of the valley at B to the valley at C does not confirm the end of the secondary reaction indicated by the next peak in the DJIA. A strict adherence to the Dow Theory would wait till the peak in 11/98 to declare a return to the uptrend. In actual fact a confirmation could have been declared as soon as the DJTA exceeded its previous peak between points B and C. This took place on mid-10/98. This chart was obtained by setting the compare symbol to DJIA.

  4. Volume goes with the trend. This means that in a Bull Market, the volume increases with the increase in price. In a Bear Market the volume increases with falling prices. In a limited sense the same is true of secondary reactions. This rule is only a general indication. We may see it in action in the charts of Fig. 1.2 where the volume is seen to increase with the price. In a limited sense the volume decreased during the secondary reactions at B,C to D and F to G.

  5. Discussion. This concludes the formal presentation of the Dow Theory. Its critics criticize it as taking too long to signal a change in direction specially at Market Tops and Bottoms. Another criticism is that the theory only indicates the direction of the market but does not give actual price targets. A third criticism is that the Dow stocks no longer represent the growth stocks covered by the NASDAQ (symbol COMP) and the internet stocks (symbol DOT). However many authors have computed the profit that could have been derived by a strict adherence to the Dow Theory. This is reported by Pring [9] that an investment of $44 using the Dow buy and sell signals of the Primary trends starting in 1897 would have resulted in the a profit of $18,000 by 1981. Whereas the same investment for the total period would only have resulted in a profit of $960. In the next few chapters we will consider tools that will allow us to meet the points of these criticisms.


 Bollinger Bands

In order to understand data of a random nature, it has always been the practice to apply simple concepts of Statistics. In the case of a price chart, we can obtain its deviation [image] from the following relation:-

and n is the number of steps used in the moving band of prices.

When the distribution of its frequency vs. deviation is assumed to be normal, the deviation is called a standard deviation. Bollinger [7] used the standard deviation to set upper and lower bands about the mean value of the Price P. A value of 2 is usually used to set the bands, because assuming normal distribution this value will enclose 95% of the data. The value of n is usually set to 20 to capture the Intermediate move. The band is plotted as a moving value according to

In Fig 2.1 we show a Chart of DJIA with the Bollinger Bands. We can observe that the bands do enclose most of the data. The bands expand and contract and this movement is an actual measure of the volatility. We note that when the data exceeds the bands, it indicates a powerful move. Subsequent movement quickly returns the price to a point inside the band. This is usually followed by a return to the band. We show two such actions, one on the downside at point A and the other on the upside at point B. It can be seen that the bands form range limits between which the stock price will move. The movement starting from one band and moving till it reaches the other. Movement sometimes also makes use of the middle band as a stopping point. We have also marked point C where the bands narrow before a strong move. In this case upwards. This narrowing can be formally interpreted as a line movement in the Dow Theory. By observing the chart movement near the most current point, we are able to extrapolate the price movement. In the next chapter, we will introduce further tools to be used in predicting the turning points of our chart. We now introduce Bollinger’s %b indicator. This is defined as

The %b is useful for comparing successive peaks and valleys when they move between the bands. It is an attempt to take the effects of volatility out of the picture. The bandwidth can be used to compare the volatility of two different stocks or estimating a beta value between a stock and an index such as the DJIA.

In conclusion, the reader is urged to examine different stocks to understand their behavior as exhibited by the Bollinger Band Charts. For example strong growth periods can be seen in the DJIA between March and May when the movement is bracketed by the upper and middle Bands. High Growth stocks with high volume such as Cisco (max. bandwidth of 0.2) show similar patterns. While Volatile internet stocks such as Amazon.com (max. bandwidth=1.2) tend to move between the lower and upper bands. Note how the movement of the prices continue along the trend where it last exceeded the Bollinger Bands. Finally observe that the %b of the first valley after point A is 0 and at the next valley %b=0.15. In Bollinger band analysis, this is taken as an increasing trend even though the price remains constant. Subsequent movement bears out this interpretation.


 Cyclic Analysis with Moving Averages

The traditional method of dealing with fluctuating data as exhibited by the charts is by a Fourier Analysis. In this method the behavior is separated into a harmonic series such as shown:-

However this method works best when the behavior is linear, that is to say that the amplitude constants A and B as well as the starting frequency [image] is constant over time. This linearity is usually caused by a few dominant forces. For example earthquakes are caused by the slip in a fault line, the ocean tides depend on the movement of the planets and etc.

The stock market behavior is caused by many events which timing is random. The amplitude of each cycle varies over time and the frequency is a function of the amplitude. In summary the behavior is nonlinear and a Fourier analysis cannot be relied on to provide good projections into the future. It is for this reason that the Technical Analysis community have developed a large number of tools that are based on moving averages. The number of steps N taken in a simple moving average implies a given frequency, we will refer to this frequency as the N step frequency. With this definition, the moving averages have the following three properties:-

  1. It damps out all cycles with higher frequencies than the N-step frequency.

  2. It averages the cyclic behavior for the N-step frequency.

  3. It captures the gradual changes from lower frequencies than the N-step frequency. Some damping is introduced

The moving averages can be displayed as a curve in a chart. We have already seen a 20-day moving average in our discussions of the Bollinger bands in Fig. 2.1. Strictly speaking the plot of the moving average should be made at the halfway position but very few charting services follow this practice. In Fig. 3.1 we use the combined curve to illustrate some of the properties of moving averages. Here we have added three moving averages with 20,40,and 60 steps. Since the frequency of the wave is 40, the 40 step moving average returns a straight line. It should be noted that if we had offset the plot by half the frequency, this moving average would lie exactly on the linear component of the combined curve. The 20 step moving average damps the input sine wave illustrating point 3 above. Finally the 60 step moving average almost eliminates the cyclic action and confirms the point 1 above.

Because the moving average damps out all cycles with higher frequencies, we can obtain an idea of these cycles by taking its inverse i.e. subtracting the moving average from the original data. The only drawback to this information is that it should be centered about the mid-point of the moving average.

Because the moving average with a larger number of steps changes direction slower than that with a smaller number of steps we can use this property to obtain a buy or sell signal. A signal to buy requires that both averages are moving in the positive direction and the faster moving averages crosses the slower one. We illustrate this with Fig.3.2 where two moving averages with 20 and 40 day steps are used. The point A indicates such a buy signal. It is interesting to note that the Japanese refer to this action as a “Golden Cross”. There are two false crossings at point B and C. They did not satisfy the condition that the slope of the 40 day moving average should also be negative. The user should note that the buy signal was valid for most of the year and is consistent with our interpretation of the Dow Theory. However it is probably not an advantage to fail to detect secondary reactions. These signals will of course be useful to long term investors. Shorter moving averages will capture the secondary reactions at the price of more crossings. There is another piece of information that can be extracted from two moving averages and that is the smoothed rate of change of the price. If we recognize that the moving averages should be plotted with different time shifts equal to half their span, the difference between their current values can be thought to form over the difference between their half-spans. Division of the first difference by the second difference will result in an approximation of the slope of the data. Similarly three moving averages with spans in the ratio of 1:2:3 can be made to yield a rate of change of slope that is to say an acceleration using the formula

Acc = (p1-2p2+p3)/ (half-span *half-span)

The acceleration can be used to help estimate the turning point at market tops and bottoms.

The time offset in the simple moving average is often inconvenient. It is possible to improve this situation by weighting the average so that it favors the most recent data. The most popular weighting is the Exponential moving average (EMA). The weighting constant is defined as 2/( span of smoothing + 1).

This weighting constant is then used recursively in the following:-

Current EMA= weighting constant*(current data – previous EMA) + previous EMA

This relation is used recursively. A simple moving average is used to start the process as an estimate for the EMA. We can now repeat the previous chart using EMA instead of SMA. This is shown in Fig. 3.3. Both types of moving averages indicated the buy signal at the bottom left. The EMA showed less crossover points that were not signals. In this respect we can expect the EMA to be more reliable in its signals.

Appel [8] combined the differential calculation with an EMA crossover concept to form what is now known as the Moving Average Convergence Divergence (MACD) procedure. In this procedure, two EMA are first calculated with spans typically equal to 12 and 26. The second EMA is now subtracted from the first. The result is plotted and at the same time this curve is subjected to a new EMA process with a span of 9. This EMA is also plotted and called the signal line. And finally the inverse of the EMA is also plotted as a histogram. This MACD is plotted in Fig. 3.4. Because so many processes are involved, the resulting plot is complex. But we can draw the following conclusion in conjunction with the Bollinger Bands also plotted in the upper chart.

  1. The first difference gives us a slope of the data if we assume that the same offsets hold for the EMA as in the SMA so that web can divide the difference of the quantities by the half span difference. We will call this the differential. The EMA (9) is based on this differential. The smoothed EMA (9) signal line is the base about which the differential fluctuates. They cross when the data is at the middle band of the data.

  2. The peaks and valleys of the Differential coincide with the peaks and valleys of the data. This helps in determining the data peaks when the data is close to the upper and lower Bollinger bands.

  3. When the Differential peaks are not consistent with the data peaks, we have a divergent behavior. This divergent behavior is a warning of impending reversal. At the moment, the DJIA and its MACD are signaling such a divergence. The highest peak in the DJIA is not confirmed by a higher peak in MACD.

  4. The difference between the Differential and the EMA(9) is plotted as a histogram. This difference is a measure of the attraction acting on the Differential to pull it back towards the EMA(9). In other words, this difference cannot stay large for too long since cyclic behavior demands that it returns to zero before it crosses into negative territory. The half span difference of the differential is 7 (assuming the SMA values). The histogram can be multiplied by this constant to obtain an estimate of how far the current data point is from the middle band.

  5. The successive valleys of the MACD can be used to estimate the span of the dominant cycle. We note that its frequency varies with the amplitude of the MACD.

  6. The MACD amplifies the cyclic nature of the market. It gives clear reversal signals, identifying every intermediate cycle. We will devote a complete chapter to linking the traditional techniques of Technical Analysis by linear edge projections with combinations of cyclic components. For the moment we note that these same techniques of head and shoulders, trendlines, triangles and channels also work for MACD since they are simply differentials of the cyclic components. The Differentials magnify the salient features of the data so that such techniques are even more effective when applied to MACD.


 Applying the Bollinger Bands and MACD Combination

We will now use our combined Bollinger Bands and MACD to analyze the movements of the Dow for the previous year. In order to help with the discussion, we show the MACD portion of Fig. 3.4 with a number of trend lines, mostly drawn to the histogram peaks.

Starting from the peak in mid-august we get a sell signal at the crossing of the signal line (-ve). We then have a tentative crossing (+ ve), but the uptrend line A indicates deferred action until it cuts the zero histogram line. At this point the signal line emits a new (- ve) signal. The DJIA continues downward until the next crossing of the signal line (+ ve) to the new peak at the end of September. The next crossing turns into a line movement followed by a continuation (+ve) signal one week into October. The contraction of the Bollinger bands, suggests caution on the previous down move and permits a wait till this next crossing signal(+ ve) in the second week of October. The trend line B and the signal line crossing(- ve) in late November ends the up move. A signal (+ ve) is next given in the last week of December (also supported by the touching of the lower Bollinger band. This signal is reversed In the second week of January. The next crossing takes place one week before the end of February. The trend line D indicates a wait until the beginning of March, so that we wait until the next signal crossing (+ ve) that takes place at the beginning of March. This is confirmed by an expansion of the Bollinger Bands. The level E line shows a target of the up move. Then there is a short down move until April when a new signal crossing is made (+ ve). The target is the previous highest peak. This is followed by a move down, until a new signal crossing is made in mid June. However the line F indicates that this is not a true (+ ve) signal. The next valid signal crossing at the end of June (+ ve) is accepted. This takes us to the current position where the current MACD line is divergent with the price indicating caution on the up move.


 The COMP.IIX Theory

In the formulation of the Dow theory, we have taken advantage of the orthogonality of the two indices where the Industrials are assumed to act completely independent of the Transports so that when they confirm each other, the reason can be attributed to the Market. There is a need for a similar theory that can be applied to the NASDAQ composite stocks (COMP), since these are the technology stocks which represent the high growth area of the economy. Instead of looking for an index that is orthogonal to the COMP stocks we will consider an index with stocks that are aligned with it. In general a sector index of a class of stock that are contained within the COMP, and has the same reaction to the Market forces, can be said to be aligned with it. Therefore any major sector within the COMP can be considered and our general conclusions can be applied to it. Because of the importance of the Internet stocks we will consider using the Amex Interactive Internet New Index (IIX) , The Street.com’s DOT index can also be used going forward, but the IIX has data going back a few years whereas the DOT currently only has half a year’s data.

First we will compare the COMP and the IIX theory over two years. We can observe that though their absolute movement are not equal, their direction of movement are similar. This is shown in Fig. 4.1 and Fig.4.2. The latter figure shows the MACD obtained for the IIX. Starting from the bottom point A in Fig. 4.1 we move upwards until the first secondary reaction at B. (confirmed by both curves). Then there is a non-confirmation of the downward move at C (the reader can recall that there was a similar non-confirmation for the Dow). Secondary reactions are then shown at points D and E. We use the comparison of the MACD behavior to emphasize the alignment of the two indices. A comparison of the two MACD plots show similarity, particularly at the peaks and valleys. We will denote this combination as the COMP.IIX theory and, because of the above comparisons, assume that all the Dow Theory Assumptions will also apply here. This gives us an important tool to predict behavior in the more volatile Internet sector.

The discovery of the COMP.IIX behavior leads us to speculate that the major indices of the Dow, S&P(SPX) and NASDAQ are aligned. We obtain an affirmation of this in the comparison plots of Figs. 4.3, 4.4 and 4.5. The last two diagrams showing the MACD plots for the SPX and the COMP respectively. From this we can postulate an extension of the Dow Theory as “The SPX and COMP indices can be substituted for the DJIA in the Dow theory”. Similarly, the IIX and/or the DOT can be substituted for the DJTA in the Dow Theory. This allows us to use the most appropriate Index for determining the behavior of an individual stocks.

Finally we conclude this discussion by noting the strong influence of the Market on all types of stocks. This is the reason why we started our discussion of Technical Analysis with a study of the Indices.


 Rational expectations

Rational Expectations

We have now seen how the major indices are a good representation of the market. In recent years, we have seen the increasing popularity of indexed Mutual funds which use a basket of stocks to reproduce the behavior of the indices. We will explain this by examining the behavior of a stock portfolio which will give us a means of examining the link between individual stocks and portfolio behavior. In order to do this we will turn to simple concepts of statistics which have traditionally been used to characterize random motion. It is well known that the difference of the log of stock prices ( hereafter referred to as simply the difference) approximate a normal distribution and in general these prices also are well represented by the statistical measures such as standard deviations. Markowitz[10] used these concepts to develop the theory of an efficient market. This observation has led some to shape the theory of this behavior referred to as the random walk theory. Popularly explained as the stock prices resembling the movement of a drunk wandering on a plain. The first characteristic of the random walk theory is the normal distribution of the price difference. The second characteristic is that the dispersion of the distribution , as measured by the standard deviation, rises with the square root of the holding period or time. Murphy[11] has shown how this behavior can be used to characterize stock movement and how it can be used to extrapolate the observed statistics into the future. We will call these projections rational expectations because they are based on a concept of symmetrical and normal distribution of the price differential. That is to say, the assumptions do not have a bias in any direction. Such a viewpoint might be of concern to many since a viewpoint that can be taken is one in which the selection and inclusion of stocks in one’s portfolio has all the factors favoring a price appreciation. However many fund managers have been confounded recently by the statistic that the indexed funds have outperformed 80% of the other funds.


 The random walk model

Changes (difference) in the price of a stock may be represented statistically as the sum of two independent random elements, one peculiar to the market and the other to the stock. Because of the symmetry assumption, the expected value of these elements is zero and the standard deviation is about the same for each—roughly 18% per year. The following three equations describe what happens to the price of a stock

Where s is the standard deviation

Subscripts m and s denote dependence on market and stock respectively

s(1) is the standard deviation in unit time steps; and

t is the new time step of the stock (which also results in an estimate of t times the previous holding period)

The expected mean of the log differences is zero, and the observed distribution of the differential is approximately normal. In the following we will discuss the implications of these equations.

The expected change in the logs of price is zero, yet the expected change in price is positive. This is because the mean of the antilog is positive and can be calculated from eq.(5.2).


 Risk reduction in a portfolio

Because the part of the change in price is due to an individual stock and is independent of the market, we can reduce the risk in a portfolio of stocks. This assumes that the stocks are independent of each other and also that we place equal investments in each stock.

The formula for calculating the standard deviation in a portfolio is now

where n is the number of stocks in the portfolio. When n is large, the last term reduces to zero

and the standard deviation is only dependent on the market.

We can now see that an indexed fund produces the standard deviation of the index. It is important to remember that this is obtained by assuming an equal amount of investment for every stock in the portfolio so that the assumption of normal distribution can result in the same standard deviation as that of the indexed fund. In the other cases of alternate ways of building a portfolio, the additional assumption must be made that the market component is roughly half of the total change of a stock given by its beta factor. However we may use a linear regression to help us define a straight line as given in the following:-

where alpha [image] is the intercept with the y-axis at x=0. Alpha is an estimate of the standard deviation due solely to the individual stog. We must emphasize here that both Alpha and Beta are average values that should be defined over a long time.

We summarize the effect of number of stocks (table 5.1) and holding period (table 5.2) on the standard deviation.

Num. of stocks

            • 8
            16
            32
            128
            Inf.
    Standard deviation
    1. 0
            0.85
            0.68
            0.63
            0.59
            0.54
            0.50
    Table 5.1. Effect of number of stocks

    Time

            • 10
            20
    Standard deviation
    1. 0
    1. 41
    1. 73
  • 0
            • 2.24
    3. 16
  • 47
    • Table 5.2. Effect of holding period

    Fig. 5.1 Shows the distribution of the S & P 500 index for the last seven years. This is the order of approximation that can be made to a symmetric normal distribution. Fortunately the statistical parameters are not too sensitive to these factors. The SPX data was obtained on a monthly basis. A standard deviation of 0.036 was calculated and using the factor of 1.73 (Table 5.2) the standard deviation was projected to be 0.0626 for a holding period 3 times as long.. This may be compared with a calculated standard deviation of 0.058 from the quarterly data.

    The reader is referred to Murphy[11] for further elaborations of the implications of the random walk model. The objective of the presentation here is to establish a rational basis for projecting the effect of one’s investment and also bring out the importance of approaching investing from a portfolio point of view. The effect of the portfolio is to reduce the risks peculiar to individual stocks. It is clear that if one subscribes to the model presented here a strong case can be made for investing in indexed funds as well as the possibility of combining mutual funds to tailor the expected returns.

    Finally, we obtain an estimate of Beta for the last year by using Microsoft Excel to perform a linear regression of the SPX vs. MSFT for the last year. This analysis yielded a Beta of 0.113. It is usual to normalize the value of Beta and express it as a comparison of percentage returns. For this we use the values of MSFT=56.4 and spx=1140.This results in a beta of 2.28 and this can be compared with the long term Beta of 1.33 provided by a stock service. A value of 8 was obtained for Alpha from the intercept with the MSFT axis. Note the high volatility in the Beta value that is usual in a high tech. Individual stock.

    Fig. 5.2 gives a plot of MSFT vs SPX used to extract the above data. The value of Alpha is of some interest since it is the only available measure of the change in the value of the stock that is not a function of the market.


 Mutual Funds as Market Timing Instruments

We have already pointed out that eq. (5.4) favors the holding of a large number of stocks in a portfolio to reduce the risks of individual stocks. Mutual Funds are designed to take advantage of this by limiting the percentage of the funds which may be invested in a particular stock. Moreover by favoring an invest and hold strategy, the Mutual Funds also take advantage of the scaling power of time as represented by eq. (5.3).

As an example of the flexibility of tailoring a portfolio, we mention Mutual Funds such as the ProFund and Rydex which have developed funds that behave like indexed funds or some multiples of an index such as the S&P 500 (SPX). The multiple can include a Beta of –1 which profits from a falling Market. Such Funds usually carry a no-transaction fee policy to encourage frequent timing changes in the ratio of investments among their family of Funds. In Fig. 5.3 we show a plot of the UltraBull Fund from the ProFund group. This Fund (ULPIX) has the stated intention of mimicing the SPX with a Beta of 2. A linear Regression analysis with Excel produces a Beta value of 1.56. An examination of the chart shows a low volatility and hence the achievement of the desired mimicing. The deviation at negative values of SPX in the chart is due to payment of a dividend. A more rigorous test showed that the MACD charts for both the SPX and ULPIX produced the same buy and sell signals.


 Cyclic Behavior

The early methods of Technical Analysis [5] consisted mainly of working with the up and down trend lines in conjunction with Volume plots. When breakout takes place parallel lines drawn to the other trend line usually predicted the maximum movement of the breakout.

In this chapter we will show how the traditional patterns can be simulated with simple cyclic curves combined with a linear long term movement. We first assume that our long term movement reverses direction represented by the up and down line in Fig.6.1. This gives us the head and shoulder pattern

The arrow lines mark-off equal distances from the top of the head to a trendline drawn across the neck. The lower arrow indicates the expected movement. The head and shoulders pattern is often accompanied with a reversal of the breakout back to the up trend line (now horizontal) at point A. Following our already familiar rule that volume follows the trend, we can expect an increase in volume as we move up the left shoulder and a larger volume again when we move up the head. The volume tails off as we move up the right shoulder. Finally there is an increase in volume on breakout, low volume on the pullback (towards the horizontal neckline) and increase in volume on the continuation of the new downward trend.

In Fig. 6.2 we obtain a double top pattern by shifting the maximum long term point 90 degrees back. This time the up trend line is drawn through the lower points of the intermediate cycle. And the expected movement is shown by the lower arrow line.

Finally we replace the long term lines with another intermediate curve of a different frequency. The combination is shown in Fig. 6.3. We note that the down trend line (along the combined cycle peaks) and the up trend line (along the combined cycle valleys) form a triangle. We also note that the triangles are not necessarily formed at market tops and bottoms. The expected movement is given by a line parallel to the up trend line and at the point where the downtrend line first intersects the combined curve. Further examination of all the patterns reveal that the maximum movements are completely determined by interactions between the cyclic and other curves that were used to simulate the patterns. This is the reason why the patterns keep repeating themselves across different stocks as well as for different variables. We have already remarked on their use in MACD plots.


 The Spring Mass Analogy

The simple harmonic motion (sine curve) that we used for the intermediate cycle can be generated by a spring –mass device such as that shown in Fig.6.4.

Fig. 6.4 Spring –Mass device.

We denote the spring stiffness as k and the mass as M. The dependent variable is the vertical displacement and is given by u according to

u = Amplitude * sin ( [image] t) (6.1)

The frequency of this device is given by

This frequency is also called the resonant frequency. It has the property that it picks up all forces (and components) applied at this frequency and magnifies its effect.

In our analogy the volume V is taken as the dependent variable so that

the stiffness k = d P/ d V (rate of change of Price P with respect to Volume V).

The Mass M is taken as the Float multiplied by the price of a stock. It is not intended that one be able to calculate the cycle frequencies directly. Rather we wish to obtain estimates of important cycles by measuring the frequencies from a chart for one stock and scaling the result by our estimates of stiffness and mass for any other stock. To obtain our stiffness quantity we use the maximum range of the Bollinger Bands divided by the three month average of the volume.

The Following values were obtained for Dell Computer’s chart.

Range of Bollinger Bands = 16 , average Volume = 32 Millions

Float = 1952 Millions, Price $40.00

By examining the peaks of the MACD plot in Fig 6.5 we obtain an estimate of 1 ½ months per cycle. We wish to obtain an estimate for Amazon.com. Its values are given by

Range of Bollinger Bands = 50 , average Volume = 8.3 Millions

Float = 63 Millions, Price = $122.00

By using proportionality, we can write

From this we estimate that the dominant frequency of Amazon.com is roughly 11 times faster than that of Dell and so its peak to peak period is 30 * 0.09 = 2.7 days.

This can be verified by the hourly chart for Amazon.com given in Fig. 6.6

The four successive peaks on the chart are marked by short vertical lines. These give cycle periods of 3, 2.4 and 2.7 days respectively. The results are good and support our use of the spring-mass analogy. The short resonant period obtained for Amazon.com is typical of all Internet stocks. Our results indicate to us that we must adopt such short periods when we chart Internet stocks or else we could miss the most important behavior. The reversal moves can flash their signal and the events have taken place before they show themselves on the day charts. This is why the traditional Technical Analysis often fail when applied to Internet stocks on daily charts.


 Fibonacci Profit Objectives

We will now examine our basic cyclic model to obtain estimates of the distances between peaks and valleys. We will call the next peak or valley an objective point (OP). We repeat our simple cyclic model in Fig. 6.7.

We wish to find the price change between points AD. This is made up of a long term movement plus two cyclic amplitudes. However we want to extrapolate it from currently available data. Suppose we first move from A to B. This gives us a local maximum since the next move is from B to C. It is at C that we wish to estimate the move from C to D. We can see that from symmetry about the line AD, the move is the same as that from A to B. We will refer to the price change from C to D as the OP. The question arises whether we can put upper and lower bounds on the move. We will refer to these objective points as expanded objective points (XOP) and contracted objective points (COP). Dinapoli [12] suggested the use of Fibonacci series to define the bounds. The Fibonacci series has the property that the current number is the sum of the two previous numbers. This is (1,2,3,5,8,13,21…..) This is a series that increases at a faster rate than a linear series but slower than a quadratic. Since our bounds will be taken from three consecutive numbers in the series we can control our rate of change by selecting the middle number of the three and normalizing our series. Selecting the number 8 , we obtain the three numbers (….,0.618,1.0,1.618,….).

This is then used to define our objective bounds as,

COP = C + 0.618 * CD

OP = C +1.0 * CD

XOP = C+1.618*CD

The same reasoning applies in a down move . We only need to change the + sign to a minus sign in the above equations. In Dinapoli [12] extensive case studies are given to demonstrate the efficacy of the Fibonacci objective points applied to high publicity predictions of market turning points. The reason this method is introduced here is that we need a method of predicting peaks and valleys that is not dependent on alternatives such as the Bollinger bands when we establish cyclic projections in our next chapter.


 Projecting with Cyclic Analysis

In this section we use cyclic analysis to project the behavior of stocks in the future. We follow the principles of nested envelopes developed by Hurst [1]. However, we will modify the actual procedures used so that we can rely on more numerical analysis rather than the intuitive sketching techniques used by Hurst. In order to create the nested bands, we have developed an Excel program to operate on downloaded chart data. In this case the data was obtained from the Microsoft Investor. The main task is to calculate two moving averages and perform some curve fitting. These moving averages are calculated at 10 day and 40 day intervals respectively. The 10 day moving average is used to capture the main cyclic behavior of the stock. While the 40 day moving average is used to capture the longer term movement and establish bands for the ten day moving average bands to move in between. Typically the bands for the 10 day moving average are initially set to 8 per cent above and below the moving average. The bands for the 40 day moving average are set to twenty percent. Both the bands and, to a lesser extent, the moving average intervals are changed to obtain the best fit of the data. The moving averages are plotted with their values centered within the moving average. We discuss our procedure in conjunction with the data obtained for Dell computer on 7/15/99. In order to perform the extrapolation from the then current data, we take the following steps:-

  1. Order the initial data in ascending order, earliest data first. The day data is obtained for the last year.

  2. Adjust the bands of the 10 day moving average to 7 per cent to enclose most of the data as shown in Fig 7.1.

  3. Adjust the bands of the 40 day moving average to 15 percent to enclose the peaks and valleys of the upper and lower bands of the 10 day moving average.

  4. Use the arc of a circle ( for constant curvature) to fair and extend the outer bands of the 40 day moving average. This extrapolates the nesting bands beyond the current data. The 40 day moving average is also extended in this way. This last is useful in helping to extrapolate the bands for the 10 day moving average. The Fibonacci Objective Point OP of 42 is used as a guide in this projection.

  5. Draw in the extrapolated bands for the 10 day moving average using the extrapolated bands of the 40 day moving average as turning points for these bands. Use the curve drawing feature in Excel to perform the drawing. The 10 day moving average bands should move with the same cyclic movement that it did before the available data was exhausted.

  6. From the chart it is possible to estimate that Dell is close to its estimated maximum value of $45.00 for this cycle. In order to actually determine a better estimate of the maximum, we need to turn to a 10 day half-hourly chart for Dell computer using Bollinger Bands and MACD.

In summary we have shown a procedure for extracting two cyclic behaviors for periods of 10 and 40 days. We have shown how the two cycles can be used to extrapolate the behavior in the future. The reader is advised to become familiar with the technique by using data series that are purposely terminated early so that the extrapolated results may be compared with actual results. In Fig 7.2 we show a similar extrapolation for DoubleClick Inc., an Internet Stock.

The data fit was obtained by using 11 percent bands for the 9 day moving average and 20 percent bands for the 41 day moving average. Note that it was harder to fit the peaks of this data. Perhaps a 7 day moving average would have provided a better fit. Again, the maximum for this cycle is estimated to be close to the current time. An estimate of $115.00 was obtained compared to a current data point of $100.00. In addition one can obtain an estimate of a price drop to $90.00 in a continuation of the cycle.


 The Nested Bands Model

It is useful to try to draw some general conclusions for this model. The faster moving 10 day average captures all the behavior with frequencies at and below its frequency, so that the bands will capture the fluctuation of all cycles with higher frequencies. The bands at a certain per cent from the moving average can be seen as an averaging of the high frequency cycles. Similarly the slower 40 day moving average captures all the behavior with frequencies at and below its frequencies, and this is the longer term behavior. The bands for this moving average enclose the faster moving average plus its bands i.e. it encloses the whole stock movement. By splitting up its movement in this manner we have been able to extrapolate with some accuracy. If we examine both plots of Dell Computers (Fig. 7.1) and DoubleClick Inc. (Fig. 7.2), we see that the peaks formed on its way to the absolute peak are governed mostly by the slope of the long term moving average. While at its absolute peak, the long term moving average does not increase (by definition). Instead the higher cycle frequencies about the shorter term moving average expands significantly. The peak behavior is thus a function of only its higher frequency cycles.

The same conclusion can be drawn when stocks move down in a secondary reaction.

We can use this to explain the success of the Gary B. Smith [13 ] method of trading. We shall refer to this as the GBS method of trading. This method uses a breakout into new highs as a buy signal. The breakout requires an increase in volume and also that another peak should not have formed in the previous six weeks. The reason given for this method is that there are no resistance points above a new high. This method expects a 5 per cent gain for each trade. In explaining this with our model, we would say that in new peak situations when the stock is not at its absolute peak, only a current peak, the six weeks increase due to our long term cycle should exceed the 5 per cent exit point. Indeed one could use the slope of the long term moving average to obtain a better estimate of the increase. In absolute peak situations, the expansion of the high frequency behavior (volatility) again results in the required increase of 5 percent. The GBS does not use the same rules for downward movement, using a $1.00 negative breakout as a buying signal and abandoning the need for a new low. It can be seen that there can be advantages to applying symmetrical conditions on the downside using the model described here. In this case we only ask that peaks and valleys be considered if it had not been reached since its last absolute bottom and top respectively.

There are other buy signals that can be used for our model to gain more movement per trade, for example the crossing of our long term moving average. This is actually the equivalent of using the crossing of the MACD signal line. However in the present context we have the additional guidance of our extrapolated bands.


 The Nested Bollinger Bands

In this chapter we have examined the use of simple moving averages together with fixed constant bands. One drawback to the nested bands model is the need to extrapolate the projection bands from their lagging position in the moving average band. Also we are looking for charts which can be obtained directly from a charting service. We turn our attention to the Bollinger bands since these bands do perform well when they are plotted without offset. We use the same moving periods of 10 days and 40 days respectively. Fig. 7.3 shows such a chart for INTC.

The 10 day bands(red) were adjusted to 8 days to give a better fit to the data.The 40 day bands (Blue) show the desired envelopes. The MACD is also plotted at the bottom. The reader can now project from the current position. The respective Bollinger bands are a good guide. At the same time when the price line crosses the moving average line, it is taken as a reversal. Because of this sudden reversal and, the nearness to the upper bands, we can only project an increase for a short distance before we can expect another reversal. This projection is shown at the top right side of the chart. Note from the chart that one has now got to get used to the changing size of the Bollinger bands. Note also that in up trends, the faster moving average tends to reverse at the mid-line of the slower moving average. The crossing of the price line with the slower moving average indicates a tendency to continue to the further band.

This chart was produced by the Real-Time Trader software, North American Quotations, Inc., www.naq.com . This software had the option to include two Bollinger band plots with different N-step bands. Alternately, it is easy to modify the previous Excel program for nested bands so that it can calculate the nested Bollinger bands. The Excel function to calculate the standard deviation is a big help in this respect. In Fig. 7.4 we show a plot for BRCM which was obtained on 7/28/99 . This was just at BRCM’s valley and projected that it would reach 145 in its next move.


 Volume Considerations

The trading Volume is the single most important quantity in the analysis of a stock as well as the market behavior.

Fig. 8.1 Chart with Price , Volume + and Money Flow

Yet all we know about it is that it goes with the trend and also that it accompanies a breakout.

In Fig. 8.1 we show a basic plot for Microsoft. This plot uses the black color to indicate volume for up-days and red color to indicate down days. In order to discuss volume further we introduce the following assumption of a constant price to volume ratio. In actuality there is a decrease of this ratio with price movement. In addition to looking for high breakout volumes, we also would like to see a confirmation of the trend with increasing volume. We can see that the movement from A to B is consistent. While movements from B to C show a reduction in volume. The divergence increases with movement from C to D. This divergence indicates a forthcoming reversal.

From the movement from A to B we estimate the price /volume ratio to be 0.014 per Million shares.

We can write the capitalization of a stock as the product of price P and outstanding number of shares N.

Capitalization C = P N (8.1)

Taking the differential w.r.t. the volume V, we have

dC = N dP/dV dV (8.2)

assuming a constant number of shares.

If we now assume that the volume is broken up into up ticks and down ticks, we can use t, the up down tick ratio of volume to write the equation in terms of up and down volume denoted by dV+ and dV- respectively.

Thus

d C = N dP/dV (t - 1)dV- (8.3)

where dV+ = t dV- and the incremental Volumes are assumed to be positive.

Assuming that t remains constant we obtain a day relation of

C = N dP/dV (t - 1) [image] V- (8.4)

where the prefix [image] indicates a change for the day.

If we only take the value for 1 share, we obtain the money flow going into or out of the stock. This value is also shown plotted in the lower chart of Fig. 8.1. Note that the money flow makes fewer assumptions on how the terms are aggregated in eq. (8.4).

Alternately, we can now sum this relation across a market and obtain an average price volume ratio and introducing the advance to decline ratio a.d.

C = N dP/dV (a.d. - 1) [image] V- (8.5)

C and V are summed quantities and N, dP/dV , a.d. are averaged quantities.

We conclude that the term (a.d. –1)* [image] V- can represent change in capitalization, ie. The increase in market value. It is usual to assume that the volume can also be averaged out so that only the cumulative a.d. line needs to be charted.

We can also see that integrating individual stocks with time in eq.(8.5) also results in establishing the number of new highs and new lows. These volume based charts together with oscillators built on them have a large following in the Technical Analysis community. Their preference over the more complete money flow charts is due in part to their higher volatility so that they magnify the market behavior. However a large change in the cumulative a.d. line can mask a strong advance or decline of the large capitalization Stocks. This does not happen with the Money Flow charts.

Meisner [14] presents the volume based market indicators together with some insightful comments. Alternatively, the Decision Point site http://www.decisionpoint.com/DailyCharts/DailyMenu.html

Also provides many volume based indicators. In Fig. 8.2 we show one such chart based on the stocks in the N.Y.S.E.

Fig. 8.2 Advance-Decline Line


 Money Flow

So far we have examined volume tools that can only be applied to determine Market Index trends. We need a tool that can also be applied to individual stocks. We can obtain one by considering Money Flow. We rewrite eq. (8.3) in a more convenient form.

Now we assume that the stiffness term is proportional to the price P, so that we can introduce the incremental money flow equation

where M is the Money Flow.

We will now integrate eq. (8.6) numerically by sampling on a daily basis for a period of 14-days to obtain moving average positive and negative money flows, M+ and M-. We will obtain an oscillating measure by taking the ratio of the money flows.

Money Flow ratio = M+ / M- (8.7)

Which we will present in normalized percentage form as the Money Flow Index (MFI) by multiplying the Money Flow ratio by 100/(M+ + M-).

We interpret the MFI in the following two ways.

  1. The MFI of 80 and 20 indicate overbought and oversold conditions respectively.

  2. Divergences between the MFI trend and the price trend indicate imminent reversal.

Fig. 8.3 shows the MFI chart for the DJIA. Note that the price of the DJIA has also been normalized so that the divergences may be easily recognized.

In some cases, an index such as the IIX or DOT is not reported with volume data. In such a case we can proceed directly from the price change, returning to eq. (8.3b) we can write

C = N * ( [image] P+ - [image] P- ) (8.3c)

by proceeding as before, we arrive at a Price change ratio

Price Change ratio = P+/ P-

Again we normalize this to give us a Price Change Index (PCI). Fig. 8.4 shows a plot of COMP with both the MFI and the PCI plotted. The two indices agree within 2 percent.


 Nested Bollinger Bands for MFI

The main reason for charting the MFI is to determine the reversal points. It is also desirable to estimate these peaks and valleys in advance. In order to do this, we employ the Nested Bollinger Bands to separate the price into fast and slow components. Here we note that we got improved results by using a 50 day period for the slow band. The nested Bollinger bands together with the normalized price are shown in Fig. 8.5. As per our normal practice we have drawn the projected fast and slow bands. Note that it is difficult to project a changing band, it is better to project with a bandwidth using the last observed 2 times the standard deviation. From an examination of the chart, we conclude that nested Bollinger bands can be used to estimate the near future behavior of the MFI. In particular the slow Bollinger bands do track the peaks and valleys of the MFI.


 Integrating the Technical Analysis Tools

We have covered a range of powerful tools, each of these tools can be applied by itself to make decisions on a trade. However the tools become much more powerful when they are used in combination with each other. In the following we propose to deploy our tools in layers and somewhat reminiscent of the layered defense proposed in the star wars. We wish to construct our layers in such a way that after each successful application, the risk of failure is reduced a certain percentage. This means that we should not use tools which use the same basic parameters. As a first step, we recognize that for an individual stock and following Chapter 5, half the risk resides in the market. Hence we will analyze both the market and each individual stock allocating an equal weighting to both. Our three layers will consist of DowTheory and/or its extension, Market Analysis and Individual Stock Analysis respectively. The analysis of all three layers should point in the same direction. Any disagreement means a disqualification to trade in the selected stock in the direction selected.

Dow Theory (risk factor 0.3)

The relevant market index can be subjected to the Dow Theory and/or its extension. This will be the overall filter to determine suitability of the trade or investment.

Market Analysis (risk factor 0.3)

  1. The next peak or valley can be estimated by the combined Bollinger Bands and MACD.

  2. The next peak and valley can be estimated by Nested Bands and MACD

  3. Confirmation of the trend with volume and MFI.

Individual Stock Analysis (risk factor 0.3)

  1. Determine the next peak or valley with the combined Bollinger Bands and MACD.

  2. Determine the next peak or valley with the combined Nested Bands and MACD.

  3. Confirmation of the trend with volume and MFI.

The final risk factor will be obtained by taking the continued product for all the risk factors.

Our method of scoring will use the assigned risk factors and add the same factor for each disagreement of a tool. Thus a perfect agreement will give us an overall risk factor as the product of the three factors.

Risk factor= 0.3 * 0.3 * 0.3= 0.027

Disagreement or an unclear Dow theory together with a disagreement between methods 1 and 2 for the individual stock will give us

Risk Factor= 0.6 * 0.3 * 0.6 = 0.108

An increase of the risk by a factor of 4. The prudent analyst would consider this increase in risk barely acceptable.


 Case Study of Microsoft

In this section, we will apply the above strategy to study the behavior of Microsoft during the reversal in April. We will carry out the analysis for April 26, 1999 and then compare projected data with actual data. We will use the following table 9.1 to record our results.

Symbol
Method
Current
Days to peak
Subsequent
Conclusion
Comp
Extended Dow
bull
2-3
-ve but bull
bear on second cycle
confirm
IIX
Comp.iix
bull
2-3
-ve but bull
bear on second cycle
confirm
Comp
Nested Bands
2600
2-3
2300
Confirm bear
Comp
Bollinger MACD
2600
0
2400
Down move
Comp
Volume
MFI
Less
Up, but divergent
Less
Not known
less
Trend down
Down soon
MSFT
Nested Bands
90
0
70
down
MSFT
Bollinger MACD
88
-5
80
down
MSFT
Volume
MFI
Lower
At mid range
Less
  • alley past
less
Down
Neutral at mid range

Table 9.1 Integrated Technical Analysis of MSFT

The Charts supporting the conclusions are shown in sequence. The relevant conclusions have been drawn from them and they are recorded here in sequence:-

  1. Original movement of Comp still maintains Bull trend. This turns bearish after the second projected cycle.

  2. The same conclusion can be drawn from the nested bands for iix. Projection suggests a bear move (secondary reversal).

  3. The Volume trend is down for Comp. MFI in Fig 9.6 shows divergence and confirms down soon.

  4. Projection of 2300 for Comp. Large move down that would be a secondary reversal.

  5. Lower Bollinger band and downward MACD suggests move to that band and gives an estimated down move to 2400.

  6. Volume confirms downward trend. The a.d. line is not reliable here because of the continued poor performance of the small caps. MFI in Fig. 7 is in mid-range and neutral.

  7. MSFT estimated to go to 70 in the down move.

  8. Lower Bollinger Band suggests move to 80.

  9. Volume confirms down move in a secondary reversal.

Conclusions.

Comp.iix projected to be Secondary reaction in a Bull market. Comp is down. Msft projected to move down by up to 15%. All the charts confirm each other. Actual move down was to $77.00 in the third week of May.


 Comparing stocks with Market Index

The three layer approach to stock selection described above is time consuming. We wish to simplify the analysis of the various stock movements described above. The first layer consists in determining the status of the Dow Industrial.Transport or Comp.Iix. This step can not be simplified. However we can simplify the Market Analysis and Stock analysis by a chart that compares the stock under analysis with that of the appropriate Index. In order to do this, we return to our analysis with nested Bollinger Bands. The stock and Market Index can be compared by using %b based on the slow Bollinger bands (eq. ). This normalizes their price movement. We will also use the Money Flow Index to help determine the next reversal. In order to complete the chart, we include a scaled value of the stock price.

Once again we use MSFT as the stock selection. Fig. 9.8 allows the stock to be compared with the behavior of the COMP stocks which is selected as the most appropriate index. A comparison of the %b shows that they are in sync. The MFI are currently slightly above 80, the point at which we can expect a reversal. Both MFI readings are at divergences with their respective price movements. The prices are below their recent peak while the MFI are at a local maximum. The conclusion from study of this chart is that now is not a good time to hold or buy this stock.

Next, we will consider INTC as the stock selection. Fig. 9.9 compares its behavior with the COMP. The recent %b movement of INTC shows that it has been exceptionally strong and not participated in the last down cycle.

The trend of the %b is currently divergent with the trend of its price. This occurs when the volatility of the stock is high. The divergence of the MFI with the price does indicate an imminent reversal of the up cycle. The two MFIs are at around 80 and they prepare us for a downturn in INTC.

As our final comparison, we will use an internet stock namely AMZN to compare with the Internet index IIX. This comparison is shown in Fig. 9.10.

The %b shows both a weak stock and a week internet sector. The MFI is divergent with the recent upturn in the price of AMZN. The comparison of the %b values shows that the weakness in AMZN is a stock specific behavior. The MFI of AMZN is now ataround 40 which is not low enough to indicate a reversal, so it appears that AMZN will still have a further downward movement in the next few days.


 Portfolio Management

The most significant advances in the theory and management of portfolios have taken place in the last 20 years. This has paralleled the growth of the Mutual Fund and the Hedge Fund. This theory starts from the separation of stock risks and returns into systematic and stock dependent factors respectively. The simplest description of it is in eq. (5. ) which describes these risks in terms of Beta and Alpha respectively. Added to this is the realization that the contributions of Alpha is minimized by averaging of the effects of the individual stocks. This is represented formally by eq. (5. ). The simplest evaluation of eq. (5. ) is by a linear regression analysis. This gives us a long term alpha and Beta value. In practice this has been found inadequate for portfolio management. Improvements to the estimation of Beta by studying its dependence on Fundamental factors have resulted in current day practice [15]. The Beta estimation is now made by studying the sensitivity of Beta to the changes in fundamental measures such as Market , Earnings, History, Size, Growth, Financial leverage.

So far a theory has not been constructed to allow portfolio management by Technical Analysis. To the writer this means that the Technical Analyst is not able to capitalize on the greatest advance obtained by the consistent application of statistics to portfolio management. This chapter is an attempt to construct a procedure for the management of portfolios with Technical Analysis.

We start by considering the linear regression plot of MSFT against the SPX in fig. 5.2. At the time, we remarked at the large dispersion about the mean. This spread can be completely accounted for by the slow Bollinger bands that form the limits of the fast Bollinger Bands.

We show this chart in Fig. 10.1 and observe that the slow bands do form the limits of the scatter about the mean.

This means that we can use the bandwidth of the slow Bollinger bands to correct for the change in Beta due to the cyclic behavior of the market.


 Formation of Portfolio

In order to form a portfolio we must first determine the risk / return relationship for each stock that is a potential candidate for our portfolio.

Formally, for each stock, we write

Beta = Beta (slow) + Beta (fast) (10.1)

For the present we use the long term Beta from a linear regression as the value of Beta (slow). We will assume that we can neglect the small cyclic changes for the long term Beta. In order to estimate the return we divide the actual change in price over the year and normalize it with the mean price.

Return (slow) = ½ of Yearly Price change / Price (10.2)

The fast return as well as the risk can be estimated by using twice the value of the standard deviation obtained for the slow Bollinger bands.

Return (fast) = 2 * Standard deviation of the slow Bollinger bands. (10.3)

We will first assume that we wish to consider a long term investment portfolio. In this case we may neglect the returns due to the cyclic effect. We can now plot the Return (slow) against the Beta defined by eq. (10.1). We use Beta as our risk measure and plot our results for a selection of Internet stocks in Fig. 10.2. The series 1 plots in the diagram show the estimated return vs. the total Beta which is assumed to be a measure of the risk. We draw the curve on the outside boundary of the results. This is called the Systematic Efficient Frontier for the portfolio candidates. We can reason that we would prefer all stocks that lie vertically above another stock because of a better return for the same risk. In Fig. 10.2 we also plot the results assuming that the investor can follow the market timing practices outlined in this book and harvest the maximum returns due to trading. We can then add the fast returns to the slow returns and obtain a higher Systematic Frontier with trading.

The variance( Beta squared) is the better measure of the risk. Because of the uncertainty of timing we adopt the estimate of the variance as the sum of the squares of its components.

Variance = Beta (slow) * Beta (slow) + Beta (fast) * Beta (fast) (10.4)

Fig. 10.3 shows the risk return diagram obtained with Variance as a measure of the risk. Once again we reason that the envelope of maximum return for a given risk forms an efficient frontier. We now see the usual convex systematic frontiers for both the curves with and without trading contributions.

In order to proceed further, we need a metric for selecting which stocks to include or exclude from our portfolio. The simplest measure is the vertical distance of the stock from the efficient frontier. This can be normalized with respect to the total return at that risk so that it may be compared with other stocks.


 Weighting of Stocks in a Portfolio

Once we have selected the stocks that will form our portfolio it is a simple decision on how to weight the stocks relative to each other. Because we subscribe to the theory of an efficient market, we bow to the opinion of the market and select the market capitalization as the optimal portfolio. Strong support for this argument can be drawn from the superior performance of the indexed SPX Funds when compared to those of the actively managed Funds. It is widely reported that the indexed funds outperform 80% of managed Funds. Suppose we use the SPX index as a proxy for the market then the optimal portfolio would be a line joining the risk free return (90 day Treasuries) with the risk return of the SPX. The linear extension of this line contains all portfolios with the same additional ratio of risk return. We say that this line is risk indifferent and call it a risk return indifference curve. Hence we conclude that all optimal portfolios must lie on this line and we call this line the Capital Market Line (CML). In other words we are free to alter the level of risk and return but cannot change their ratio. The CML is shown in Fig. 10.4.

Before we consider how to obtain an optimal portfolio that lies on the CML line, we need to consider how we can determine what is the optimal return for a selection of stocks. Continuing with our focus on internet stocks, we can imagine that a capital weighting of a selection of our stocks will result in a systematic frontier similar to the curve we obtained for the individual stocks. We note that we can have a huge selection of these portfolios by considering that a choice of inclusion or deletion of a particular stock results in a total of approximately n! possible permutations. From these portfolios, we can again form an efficient frontier such as that shown in Fig. 10.5. Next we need to determine the point on the frontier where the return to risk ratio is a maximum. We can draw a tangent to the curve at this point. This tangent forms the optimal indifference curve.

We note that we can create a combination of the optimal portfolio with a weighting of risk free bonds. This will lie on the straight line joining the risk free point and the optimal portfolio point obtained with the intersection of the tangent and the efficient frontier.

At this point we are ready to define the problem of finding a portfolio that is both an optimal point on the efficient frontier as well as one that lies on the CML discussed previously. In actuality there is very little room to maneuver since the capital weighting is prescribed. The only choice that we have is what stocks to include from the total stock set of the market or a restricted subset that we choose to operate in. We can describe the mathematical problem as one of nonlinear integer programming. The solution of this problem is a topic of current research. Currently the best that one can do is to generate a number of trials and select that solution that comes closest to the CML.

We will now obtain a Capital weighted risk return chart by using all the stocks shown previously as well as all combinations with one of the stocks deleted. This is shown in Fig. 10.6.

The lowest risk return portfolio was obtained by deleting the AOL contribution. The optimal portfolio value was found by constructing a tangent from the risk free point to the curve of the efficient frontier. The efficient frontier for these portfolios have a higher return to risk ratio by about 15%. Yet, from our previous argument we expect the optimal portfolio to lie along the CML . The only explanation for this is that the alpha factors in this restricted portfolio could combine in such a way as to result in a non-optimal portfolio. An examination of the ratio of capitalization shows that the AOL stock is 58% of the total capitalization. The diversification of the portfolio is often a strong argument for not proceeding with the capital weighting in this case. If we wish to proceed with our list of stocks to build an optimal portfolio we would have to drop AOL because of its disproportionate capitalization. An average unweighted risk for the stock combination results in a better return to risk ratio of 24%. How then should we regard the performance figures that we estimate from our attempts to construct a portfolio? The conservative way to look at it is that our portfolio will produce a greater return but at a risk that is higher than that of the CML with the same return.

We continue the discussion of portfolio formation by examining the combination of a list of COMP stocks. Here again the largest capitalization is for Microsoft. However there are other stocks when combined can match this capitalization. The return risk charts are shown in Fig. 10.7 and 10.8 for risk measured by Beta and Variance respectively.

Once again we combine our list of capitalization weighted stocks by deleting one of the stocks in turn. We obtain Fig. 10.9 , the chart of the portfolio efficient frontier.

The optimal portfolios obtained for the selected lists of stocks are summarized in Table 10.1. We note that on the surface it is possible to form portfolios that give better results than the CML. However we should remind ourselves that this neglects the specific risks due to individual stocks. From the table it should be noted that the comp stocks provide a better return because of the lower risk.

Type of stocks | return | risk | Return/risk ratio
SPXX | 0.16 | 0.216 | 0.54
Internet | 0.5 | 0.72 | 0.625
COMP | 0.45 | 0.56 | 0.71
Table 10.1 Optimal portfolio


 Risky Stocks for Negative Returns

So far we have concentrated on a selection of growth stocks. Now we should examine the opposite side of the risk reward coin so that we may have some portfolios to short when the market is in a downtrend. One could of course argue that it is possible to depend on the negative multiplication of the high Beta factors of the growth stocks. However the sudden reversals of intermediate correction of such stocks make this a risky proposition.

In order to arrive at a list of risky stocks we make use of a search engine which searches a database of stocks. In this case we have made use of the search engine in the Investor, Money Central of Microsoft Network. Many such search engines may be found on the internet. The combined parameters that were set for the search are shown in Table 10.2

Table 10.2 Search parameters and results

The search required that there was a loss of between 2 and 13% in the last week, required that the last month’s return was less than 20% and the loss in the last year was more than 20%. A limit on the capitalization was placed at $5 billion dollars since stocks with higher capitalization have the resources to fix bad situations. A lower price limit of $29 was placed to obtain the list of nine stocks. The EDP stock was removed from the list because it was an ADR with little available financial statistics.

In order to follow the same methodology as in our previous portfolio creation, we must adopt the stance that we will short these stocks. Then we obtain the risk return charts in Fig. 10.10 and fig. 10.11 for risks using Beta and Variance respectively. Note that the proper way to interpret the charts is that the negative return must increase for us to get a better return. This allows us to assume a convex systematic frontier as before. Now we label this curve as the inefficient frontier. Our risk is now of course that the stocks may rise and once again we seek the portfolio with the best return to risk ratio. This is done in Fig. 10.12 where once again we create an indifference curve to intersect our inefficient frontier at its tangent from the risk free point.

.


 References

  1. Hurst,J.M. “The Profit Magic of Stock Transaction Timing”, Prentice Hall, Inc.,Paramus,N.J.,1970.

  2. Prechter,R.R. and Frost,A.J., “Basic Tenets of the Elliot Wave Principle”,Chapter 9,High Performance Futures Trading, Ed. Joel Robbins, Probus Publishing Co., Chicago Illinois,1989

  3. Graham, B.J. and Dodd,D. “Security Analysis”, McGraw-Hill,1934

  4. Cohen, J.B., Zinbarg E.D. and Zeikel, A. ,“Investment Analysis and Portfolio Management, Pub. Richard D. Irwin Inc.,Homewood, Illinois, Fourth Edition, 1982

  5. Edwards, R.D. and Magee,J., “Technical Analysis of Stock Trends”, Pub. John Magee Press, Inc., Boston, MA, Fifth Edition, 1966.

  6. Murphy, J.J. and Murphy, J.L. “The Visual Investor”, John Wiley, November 1996

  7. Dobson, E.D. “Understanding Bollinger Bands”, Pub. Traders Press, Greenville,SC, 1994

  8. Appel, G. “The Moving Average Convergence-Divergence Trading Method, Advanced Version”,Pub. Scientific Investment Systems, Inc.,Toronto, Canada, 1985.

  9. Pring, M.J. , “Technical Analysis Explained”, McGraw-Hill Book Co., Second Edition, New York,N.Y.,1985.

  10. Markowitz, H.M. “Portfolio Selection- Efficient Diversification of Investments, Pub, Yale University Press, New Haven, Conn., 1959.

  11. Murphy, J.E.,Jnr., “Stock Market Probability”,pub. Probus Publishing Co.,Chicago, Illinois,1988.

  12. Dinapoli, J., “Fibonacci Expansion Analysis”,Chapter 8, High Performance Futures Trading, Ed. Joel Robbins, Probus Publishing Co., Chicago Illinois,1989

  13. Smith, G. B. “Technician’s Take—Three Rules For The Long Side”, Commentary, The Street.com , www.thestreet.comm ,Sept. 9, 1997

  14. Meisler, H. “The Daily Chartist”, Commentary, The Street.com , www.thestreet.com ,1999

  15. Rudd, A. and Clasing, H. K. Jnr. “Modern Portfolio Theory”, Pub. Andrew Rudd,Orinda,CA., 1988